Handout for TURBOVEG / JUICE workshop
version 1.1 (updated 2005-11-01)
David Zelený
Department of Botany, Masaryk University in Brno, Czech Republic

This handout paper is an overview of our workshop held in Taipei on October 5, 2005. Take it like a short repetition of all procedures we practiced at that workshop with some additional notes and functions I haven’t show you due to lack of time. You can also download practice data and use them to practice these procedures again. I wish you a nice day and a lot of patience :)
David
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Software introduction

The workshop is focused into the introduction of basic functions of software tandem – TURBOVEG / JUICE. No matter which sampling method you use, this software tandem allows you to enter, store, edit and analyze your vegetation data. See the software scheme:
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TURBOVEG
Installation: TvsetupTaiwan.exe contains international single user version 2.29a of the program Turboveg written by Stephan Hennekens.
Update: could be done at the http://www.synbiosys.alterra.nl/turboveg/ in the section update -after registration you will receive an update file to your e-mail address
If you are using Chinese Windows and Chinese language mode, you need to change it before launching the Turboveg into the English language mode: 
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Launch the program – click on the icon of Turboveg on your desktop; if this doesn’t work, you have to find the program tvwin32.exe placed usually at the directory c:/turbowin/bin/.
Program need to type password - User: manager, password: zostera.
Checklist: Turboveg installation for Taiwan includes checklist of Taiwan vascular plants - you can check it in the Turboveg menu: Manage > Species lists > Edit > Taiwan. However, this checklist does not include some of introduced species. From this reason I recommend to use more complete checklist Taiwan1, distributed at this webpage and compiled from the newer version of checklist. These two checklists are not compatible – they differ in unique numbers used for particular species. For further use, existence of only one widely used checklist is essential.

To add the Taiwan1 species list to the program, download the taiwan1.zip file from the web and unzip it into the directory c:/turbowin/Species/ (after that, this directory will contain another subdirectory – taiwan1 – containing three files – species.cdx, species. dbf and species.fpt). Terminate Turboveg and launch it again – in   Manage > Species lists > Edit > you will (hopefully) find the added checklist Taiwan1.

Create a new database

Go to the menu DATABASE > NEW. Fill the database name (and folder if you need to organize your data into subfolders), choose the species list Taiwan1 (if only one available, this will be taken as default). Fill the numbers “Range for system numbers” – later, if the TBV program will be used by different working teams, this range should be unique and not overlapping for each team (for trial database, fill in for example 1 to 100 for 100 relevés).. Press CREATE button. 

Entry and import of data into Turboveg
Turboveg is originally built for entering primary data into the database. It also allows a few possibilities of import data from external sources – from spreadsheet format (e.g. Excell), Turboveg XML format or canoco condensed (cc!) format. 
We will practice three ways of feeding data into the database:

1/ manual input of primary field data via Turboveg interface;

2/ opening another Turboveg database stored in Backup format;

3/ import of spreadsheet data (Excel file).

1/ manual input of primary field data via Turboveg interface

This function allows you to enter header and species data from your relevé. We will practice entry of data from Braun-Blanquette method  relevés and discuss the possibility of measured method relevés data entry.

Modify header data - before starting entering data from the first relevé, you need to check and modify the structure of header data. Default interface for entering header data contains standard items used in Europe field survey – for Taiwan standard, they need to be a little modified. 

If you have opened your database, go to the DATABASE > MODIFY STRUCTURE and open the window “Modify database structure”. You can see list of default header data items and their characteristics ( Field name, Type – C for characters, N for numbers, Len – length of the field, Dec – number of decimals used for numbers). Add items from following table:

	Field Name
	Type
	Len
	Dec
	description

	AUTHOR_TW
	C
	30
	0
	authors of the releve

	LOCALITY
	C
	99
	0
	localization of the plot site

	LONGITUDE
	N
	9
	2
	longitude

	LATITUDE
	N
	9
	2
	latitude

	BIAS_GPS
	N
	3
	0
	error in GPS accuracy (meters)

	FIELD_NR
	C
	10
	0
	your working field number

	HABITAT
	C
	99
	0
	short description of habitat conditions

	GEOLOGY
	C
	50
	0
	geological substrate (if info available)

	SOIL
	C
	50
	0
	soil type (if info available)

	X_AXIS
	N
	6
	0
	X and Y axis taken from GPS

	Y_AXIS
	N
	7
	0
	

	X_ASPECT
	C
	3
	0
	aspect of X axis of your plot

	TOPO_CAT
	N
	1
	0
	topographical category (1-5)

	ROCK_SOIL
	N
	3
	0
	content of rock in soil

	COV_DEADWD
	N
	3
	0
	cover of dead wood (%) (if estimated)

	COV_BAREGR
	N
	3
	0
	cover of bare ground (%) (if estimated)


Particular field could be added to the structure one by one using ADD button (use EDIT and DELETE button if you have made something wrong). After entering all fields, press REBUILD button to rebuild the structure of database.
Go to menu DATABASE > ORGANISE HEADER DATA for “Compose header data form and table”. Left subwindow contains AVAILABLE header items – using left mouse button, choose the items you want to use. Add these items into the right SELECTED subwindow using ADD button and SAVE.

List of recommended header items:

Country code

Date (year/month/day)

Releve area (m2)

Altitude (m)

Aspect (degrees)

Slope (degrees)

Cover tree layer (%)

Cover shrub layer (%)

Cover herb layer (%)

Cover moss layer (%)

Cover litter layer (%)

Cover bare rock (%)

Remarks

Authors

Locality

Longitude

Latitude

Bias_gps

Field_nr

Habitat

Geology

Soil

X_axis
Y_axis

X_aspect

Topo_cat

Rock_soil

Cov_deadwd

Cov_baregr

Note the difference between the field AUTHOR (C,4) in the default selection and the field AUTHOR_TW (C, 30) in the modified selection. Original field AUTHOR is using list of Europeans authors and their unique personal numbers, which is for no use in Taiwan – that’s why the alternative field AUTHOR_TW needs to be introduced. 
Add a new relevé (using Insert button on your keyboard or menu EDIT > ADD A RELEVE, or pressing icon with blank sheet on the database toolbar). First window to appear is for header data (modified according to your previous selection). Fill in all available header data including Remarks and press Save. New window for entering species data will appear (if not, go to EDIT > MODIFY SPECIES DATA ).

Please note: the numerical fields in the header data window are by default filled by zero. But zero here could have two meanings – either that you haven’t estimated this characteristic, or that this characteristic is equal zero. To differentiate these two possibilities, fill -1 to the field which you have NOT estimated, and zero to the fields which characteristic is equal zero.
Edit species data – this window allows to fill in all species data including information about the layer and cover value. For choosing particular species from the species list, type first three letters from the genera and first three from the species name – if more species names appear, choose the right one. Pressing enter skip to the next field and choose appropriate LAYER as following:

	E3
	1 - Tree layer (high) (t1)

	E3 lower (if distinguished)
	2 - Tree layer –middle- (t2)

	E2
	4 - Shrub layer (high) (s1)

	E1
	6 - Herb layer (hl)

	E0 (if recorded)
	9 - Moss layer (ml)

	juveniles
	7 - Juvenile (jl)

	lianas
	3 - Tree layer –low (t3)

	epiphytes
	5 - Shrub layer –low- (s2)


Press enter and fill the cover value. If filled wrong one, the list of available values will appear.

Press enter and add the species to the “Selected species list”. You can start filling another one. Use REMOVE and MODIFY buttons if you filled something wrong. If you have filled in the all species, press SAVE. You will see the result – in the left DATABASE window are your header data in one row, in the right RELEVE window is list of all filled species. If you want to see complete list, press the “Multi column view” button in RELEVE window (second from the left) and sort the species as you like (according to the alphabet or layer and cover).
Use file practise_data.doc for trial samples to fill up the database (file contains data made during our field trips in different parts of Taiwan).

2/ opening another Turboveg database stored in Backup format
The easiest way how to exchange databases is to use Backup/Restore function. If you have all databases closed, you can go into menu DATABASE > BACKUP/RESTORE > BACKUP RELEVE DATABASE and create backup file from the database selected from the list. This database is in zip format – the file should not be unzipped. If you want open the backup file of database, simply go again to the menu DATABASE > BACKUP/RESTORE > RESTORE, select the *.zip file with the database and restore it.

Use file hohuanshan.zip for test the import function.

3/ import of spreadsheet data (Excel file) with (or without) layer information
If you have matrix of your data in Excel file (or dbf) format, the easiest way how to import them is using function IMPORT > FREE FORMAT SPECIES DATA. You need to clean and arrange your data in this way: first row contains plot numbers, first column contains information about layer (1 for woody species, 6 for herbs – if you have data from both layers), second column contains Latin species names according to checklist and all other columns contains value for species cover of IVI:
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Save this sheet as tab delimited text format (*.txt) or DBF4 (dBASE IV+) format (dbf format is recommended). Open Turboveg and create new database for import your spreadsheet data. Go to the menu: IMPORT > FREE FORMAT SPECIES DATA TABLE and open your *.txt file. Import wizard “Import Ascii species data table” will show up. Choose FORMAT TABLE – choose “Columns tab delimited” (if you saved your data in DBF format, format selection will be made automatically) and press NEXT - data are sorted into the columns. Now select “Species column #” – number of column containing species data to be imported (if you have your species data in second column, this number will be 2) and select “Layer column #” for column with layer info (if this column does not show up in your import wizard, you are using older version of TBV – update to newer version!). Press NEXT; species names in the imported file are compared with the checklist and the information about number of recognized species will appear – unique numbers for each species according to the checklist will appear in the first column. Scroll down the list of species in your window and search for not recognized species names, which will show up in blue color – you need to find their name manually (there are few reasons, why these species could not be recognized – either you have mistyped in your import file name, or this name is synonym and you need to search for valid name, or this species is simply not included in your checklist – this will happen for some introduced species). Use mouse to double click on blue species name – it will open the window with checklist, where you can manually find appropriate species name (type first free characters of genus and first free characters of species name). Press OK – the color of recognized species will turn black and its species number will appear. Check the whole list in this way. Then choose used COVER SCALE – “Braun-Blanquet (new)” for extended BrBl scale (nine values), “Ordinal scale (1-9)” for ordinal scale. You need also mark releve you want to import – scroll the table window right and select the columns with releve – either using mouse double-click on the table header, or pressing spacer. Selected species will be marked with asterisk (*). Press NEXT. You will be asked, how to replace data from your table with used cover scale – “Replace cover code ‘?’ with...”. Choose appropriate value to replace and press REPLACE ALL. For values expressing no cover press IGNORE ALL. 

Press COMPLETE. If you succeeded, database with imported samples will appear.

To practice this function, use sample data from Woody’s master thesis in file woody_plot_data.xls (contains just wood species without layer info) or hulien.xls (contains both wood and herb species and column for layer info).
4/ import of header data from spreadsheet
Import of releve matrix described in previous paragraph does NOT allow import of header data – it has to be done separately from file of different format, using function IMPORT > FREE FORMAT HEADER DATA TABLE. Table for import of header has to be arranged in following way:
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Numbers in first column has to agree with number of releve used in previous import of species x releve matrix – they will play a role of key, connecting together species data table and header data table. Save Excell table in dBaseIV format. Use IMPORT > FREE FORMAT HEADER DATA TABLE and open import wizard; your data will show up. Specify in which fields the data of specified columns have to be incorporated. Select a column and press the Space bar or click the column header. A dialogue box appears in which you have to specify in which existing or new database field the data have to be loaded – one of them has to be selected as a key field. Press COMPLETE and check whether you imported header successfully. 
Export data from Turboveg

You can observe various export formats available in Turboveg in EXPORT menu. The most common formats you will use are these:

· Turboveg format for export to another (or blank) Turboveg database,

·  universal XML format (allows direct import to JUICE)
· cornel condensed species file (cc!) used for further analysis (CANOCO)

· JUICE input files (designated for direct import to JUICE)

· other formats (spreadsheet, MULVA and SYNTAX input files etc.)

We will practice export of data into JUICE. You can see that there’re two ways how to do that – either using XML format, or using function producing JUICE input files. If you have relatively small set of data and you want to export them into the JUICE for further analysis, XML format is best way how to do that – is more convenient and easy to handle. The second way of export/import data between TBV and JUICE requires checklist imported into the JUICE. This way is better to use if you have larger data originated from different resources and you want merge them together in JUICE. Turboveg handles the function for export checklist in format used by JUICE – go to MANAGE > SPECIES LISTS > EDIT > TAIWAN1 and use button EXPORT in “Modify species list” window. Choose “Limited list for JUICE” and export the file into the JUICE directory. 
Export data in XML format

Before export, you need to select relevés to be exported. In DATABASE window choose particular releves using spacer – selected releves will turn yellow. List of selected releves could be found in the window SELECTED RELEVES at the right part of window (if you did some selection before, you need first clean list of selected releves using function Unselect all releves (SELECTED RELEVES window, second button from the right). 

After selection, go to EXPORT > XML FILE and launch the export wizard window. Select target directory, file name and encoding (left default selection Windows-1252 (Latin 1) if you have no special language requirements for header data). Press EXPORT.
You can see the structure of exported XML file using ordinary internet browser:
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<7uml version="1.0" encoding="windows-1252" 7>
- <Plot_package UserName="TBM" Emailaddress=" Turbovegversion="2.29a (International single user version)" Dictionary="default"
Specieslist="taiwan1" Description="" ShareWithMermbersOnly="no" CreationDate="'12/10/2005"
- <Plots>
- <Plot database="Hohuansan'>
- <header_data>
<standard_record releve_nr=

1" coverscale="02" date="20050918" surf_area="16.00" exposition=
cov_total="-1" cov_herbs="15" cov_mosses="1" cov_rock="85" moss_ident="N" lich_ident="N" />
<udf_record ispredefined="true" name="coord_code" type="C" len="2" dec="0" value="01" />
<udf_record ispredefined="false’ name="locality" type="C" len='99" dec="0" value="Hohuanshan, Taroko NP" />
<udf_record ispredefined: de’ type="N" le; " yalue='240819.70" />
<udf_record ispredefined=" ude’ type="N" len="10" dec="2" value="121161.98" />
<udf_record ispredefined: "2" dec="0" value="12" />
<udf_record ispredefined: 10" dec 1/05" />
<udf_record ispredefined: "99" de cree slope, moving rocks' />
<udf_record ispredefined: ‘geology" type: 50" dec="0" value="schist' />
<udf_record ispredefined="false’ name="soil" type="c" len="50" dec="0" value="litosoil' />
</header_data>
- <species_data>
<species>
<standard_record nr="1320" cover="+" layer="6" />
</species>
- <species>
<standard_record nr="1419" cover=
</species>
- <species>
<standard_record
</species>
- <species>
<standard_record nr="3063" cover="+" layer="6" />
</species>
- <species>
<standard_record nr="3219" cover="r" layer="6" />
</species>
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JUICE
Installation: program written by Lubos Tichy from Masaryk University Brno could be downloaded free at http://www.sci.muni.cz/botany/juice.htm. Download and run the exe file.
Update: program comes through stormy development and is updated frequently. Check for newer version using quick update function – go to Help > Quick JUICE update. This function will terminate JUICE and download the juice.exe file from the JUICE homepage – you need to rewrite older juice.exe file in the JUICE directory by this newer file.

Import data from Turboveg:
· XML format data – go to File > Import > Table > From Turboveg XML Format and launch the import wizard. Open your *.xml file exported from Turboveg and select header data to be imported (at least releve number has to be selected). Press OK - if successful, releve table will appear. 

· JUICE format export file from Turboveg – go to File > Import > Table > From Turboveg or Cornel Condensed File and launch the import wizard. Select the table file and press Next. In File Parameters menu, you can select Scale of data to be imported (if you have ordinal data, choose Ordinal). Press Next and select your checklist (see above for the way how to export the checklist from Turboveg into JUICE). Press Next. If your data contains header data, select them. Press Next and finish the import procedure.
If you have no data to import, you can practice with the data we made together during my field trip – hohuanshan.wct (using Braun-Blanquet) or with Woody’s data from his master thesis woody_plot_data.wct (using IVI transformed into 1-9 ordinal scale).
Editing and sorting of relevé data

JUICE offers easy way of handling releve data – you can manually sort both releves and species (press left mouse button and move the releve number or species name), change both releve or species color (select color at the toolbar panel and press right mouse button), separate sorted releves into groups (pres SHIFT and left mouse button in header data area).  Use left mouse doubleclick in the matrix area to see the list of species and their cover for particular releve (in this window you can also find info about No. of species, Shannon-Wiener index and Equitability; if header data available, they will appear in the end of the list; at the same time, species list of this releve is copied into desktop – you can paste it into Word). Check other functions for sorting and editing in the online manual (Help > Help Contents).

Synoptic table
One of the most important procedures with vegetation data is compilation and analysis of synoptic tables. If you have classified and sorted your plot data into some vegetation groups, you will be interested in this vegetation groups’ characteristics, sorting species in particular group according to their diagnostic importance and comparison of particular vegetation groups’ composition. Synoptic table puts together all plot data and combines them according your division into vegetation groups – number of columns equals to number of vegetation groups. You can build synoptic table in various ways, based on different parameters – species fidelity, constancy or abundance. 
If you have made division of your data in JUICE (either manually or using some kind of numerical classification method) into vegetation groups separated by vertical line, go to Synoptic Table menu. Here you can choose the parameter you want the syntab be build on. Choose FIDELITY (see HELP menu for info about this parameter if you’re not familiar with). Synoptic table will appear. In head of the table, info about the used fidelity measure is provided. If you want use different fidelity measure, press well hidden button on the program toolbar (actually used fidelity measure is written on it):
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Option window will appear – you can browse the list of available fidelity measures. If connected to internet, press Help for further info. Two most often used fidelity measures are phi coefficient and u-value (hypergeometric). Choose one and close the window.

To make synoptic table more synoptic, sort the species in particular vegetation groups according to their diagnostic importance. The higher is fidelity of species for particular vegetation group, the higher is its diagnostic importance. Go to menu Sortinh > Sort Species In Synoptic Table and launch Sorting window for setting up the sorting parameters. Choose the parameter you want your species be sorted by – if using fidelity measure for syntab compilation, choose it. Choose Entire Database in Sort subwindow and press Sort. Program will ask you to define sorting limit threshold – lower threshold will sort more species on the top of the table (try different thresholds to find reasonable one; if using u-value (hypergeometric) fidelity measure, set the threshold equal 2, as this value is considered as significant. Species with fidelity higher than defined threshold value will be sorted in the top part of table and will be colored green. 
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You can see that group three has no green species – it means that no species fidelity value exceeded your threshold value. This group seems to be poorly defined and considers revision – it may be just very heterogeneous group of samples just accidentally appeared together. 

Remember – if you have about one hundred plots from one region and you will define vegetation types based on this small dataset, diagnostic species for these vegetation types are of regional validity only! The only way how to define diagnostic species of national validity is to base the definition of vegetation types on national database.
Analysis of synoptic table columns
If you have compiled synoptic table, you can go to menu Synoptic table > Analysis of synoptic columns (if this function is not available, it means that you need first to compile the synoptic table – Synoptic table > Fidelity and again Synoptic table > Analysis of synoptic columns). Scroll the bottom down panel in new window to choose the column of synoptic table you want to analyze. Press Refresh. List of diagnostic, constant and dominant species will appear. Changing threshold in each of this species list column will change the number of species getting over this threshold. The list of diagnostic, constant and dominant species for each column can be exported into Word (press Export and set parameters for export). All exports are exported into the same *.rtf file – you can find its location in File > Export > Current file: ...
Numerical classification methods available in JUICE

Some general notes: There are simply said two main methods of classification – unsupervised and supervised ones. Unsupervised methods pretend to be the most objective – they don’t allow you to affect or modify the result. But in reality they do – you still have a lot of decisions to do, starting with the most important one – the choice of a method (will you go for TWINSPAN or some kind of cluster analysis? And will you use Euclidean distance measure and Ward’s method or...?). Each choice makes the result almost totally different – and there is no objective way to say which result is more objective - you have to choose the one which seems to you the most reasonable. So where is the objectivity? 
Supervised methods presume that you have some idea about how should the result of your classification look like – usually based on expert knowledge. For example you have already built up the system of your vegetation classification and now you have collected new data and want them to be classified according to this system. If you will use unsupervised classification for your new data, the method will somehow cut your data into some number of clusters – but these will be just hardly comparable to the existing classification system. That’s why you need to use supervised classification – it will take into account existing system and according to it shape the results. COCKTAIL is one of the methods how to do that – check appropriate papers if you need to learn more. Just remember: supervised methods are not constructed to build classification system (as unsupervised methods are thought to be even if they are not either) – you need to build your classification using another method (usually your subjective experience, feeling and brain) and then use the supervised method to classify data following this classification.
TWINSPAN and Cluster analysis

The popularity of TWINSPAN is may be based on the fact, that this method does not offer too many choices – you simply just run the TWINSPAN on your data and it will produce just one result, you can just choose the level of division you want to use. And at the same time the result of TWINSPAN classification seems to bee quite reasonable, mainly because it’s based on cutting your data according to most significant environmental/compositional gradients, which usually matches your subjective image of classification of your data based on your field experience (dry versus wet vegetation types, basic versus acid stand etc). But as every numerical method also TWINSPAN works on the principle “garbage in – garbage out” – it will produce some result even on garbage data, and if you will just blindly believe in it, your results will be the same garbage. 
There is also no general rule to say if it’s better to use TWINSPAN or cluster analysis for your data – both are still in use. In last few years TWINSPAN was thought to be out of fashion, but newer studies based on randomly generated plot data show, that for some kind of data TWINSPAN gives more reasonable results than cluster (Chytry et al., unpublished). Therefore the problem is not like “choose TWINSPAN or cluster”, but much more like “choose unsupervised or supervised classification”?
If you want to use some numerical method to classify your data, remember one fact: there is no objective classification. Classification of vegetation has in fact just one reason – people have a strong need to name the things they have to work with. If you are phytosociologist, you need names for repeating vegetation types to be able draw them into the map and discuss them with other people. Different people will produce different classification of the same vegetation data, and nobody can say which one is the best and which one is bad – the criterion for good classification is that it makes sense to most of the people and that’s why it’s widely used. The use of unsupervised numerical classification tries to remove subjectivity from classification process – but if we will agree with the fact that no objective classification exists, is the effort for removing subjectivity from the classification process really adequate? There has been an agreement, that the classification process needs to be formalized - it means if different people are classified the same vegetation material, they should come to the same (or very similar) result. Using unsupervised numerical methods puts this formalization effort into the phase of recognition and description of vegetation units – with strong belief, that computer will do it better (“more objectively”) than human would. Problem is, that such a kind of analysis needs to be run on data from the highest spatial level – in case of Taiwan it should be run from the data on national level (from the whole island), in case of Europe on data from more than just one country (for example Wolfgang Willner produced very reasonable classification of central European beech forest using TWINSPAN and data from Central Europe). If you run this analysis on regional data, you will get classification valid just in those region – but to compare and merge classifications built on regional scale is almost impossible. Regional studies are important part of the survey, because they give the idea about vegetation types present in different areas – but next step have to be merging regional (and historical) data together and producing classification valid for the whole island. 
TWINSPAN in JUICE

TWINSPAN software is already implemented in JUICE, so it does not to be separately installed. Prepare table with the data to be classified and go to Analysis > TWINSPAN. Set the Twinspan parameters – choose the color of releves to be classified, set up Pseudospecies cut level and Values of cut levels (if you are using ordinal scale or BrBl scale, just use the default values), set up Minimum group size (how many releves should be in group which will not be further divided) and Maximum level of division (how many levels will the dendrogram have). Tick the field Make separators if you want releves in the table to be sorted according to TWINSPAN result and the same for Species sorting field. Run TWINSPAN and after while sorted releve table will show up. JUICE can handle six different separator line styles for six TWINSPAN hierarchies – different hierarchy level could be chosen in the “Separator hierarchy” menu in right upper part of toolbar (if you won’t use hierarchy, un-tick the field). You can compile synoptic table and run analysis of synoptic table columns to see the reasonability of classified groups.
Cluster analysis in JUICE

JUICE is able to directly handle PC-ORD and MULVA software, if they have been installed in the computer (MULVA software could be downloaded for free at http://www.wsl.ch/land/products/mulva/ - but as a DOS based program it’s not too user friendly, so go for it only if you have not an access to PC-ORD). If you have installed PC-ORD, go to JUICE menu File > Options, in Option window choose folder External program paths and in PC-ORD field fill the path to Pcord4.exe file (usually C:\Program Files\Pcord4.exe).
If you have prepared table for analysis, go to Analysis > Cluster analysis > PC-ORD. Option window will appear – it offers all options of cluster analysis available in PC-ORD. Choose appropriate data transformation (if you work with percentage data, square root transformation default is ok), fill the maximum number of clusters and choose also Distance measure and Group linkage method. Press Continue >>> to launch analysis. JUICE communicates with PC-ORD using keyboard driver – so don’t touch the keyboard until the process terminates (also don’t run any other program, which could accidentally open some window – JUICE could capture this window and try to process classification for example on your e-mails or MSN). If the classification process succeeds, new window will appear – it allows you to choose the number of clusters you want to use. Press Tree button to see the dendrogram. Press Create clusters to project the result into the JUICE table. If you will answer NO in question Discard your results of current Cluster analysis? (appearing after pressing Cancel button), you will be able later change the number of clusters in use – go to menu Sorting > Sort Releves By Cluster (PC-ORD) and launch the same window again, 
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Attached file with practice data
contains these files:

· folder TAIWAN1 – containing extended version of checklist including also some introduced species – save the whole folder into directory c:/turbowin/species/
· practice_data.doc

· hohuanshan.zip
· woody_plot_data.xls
· hualien.xls
· hohuanshan.wct and woody_plot_data.wct for opening in JUICE
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